Пользователь
0,0
рейтинг
15 декабря 2012 в 11:13

Вышел релиз FreeBSD 9.1 recovery mode

Релиз FreeBSD 9.1 вышел около двух недель (а вернее в срок, 5 декабря) назад, однако, официального анонса не было. Скачать можно с зеркала yandex mirror.yandex.ru/freebsd/releases/ISO-IMAGES/9.1
Официальное зеркало рекомендую пожалеть — пользуйтесь зеркалами (например, тем же yandex)
Также используйте svn/cvs/ctm для получения исходников и переборки, подробности можно прочитать во FreeBSD Handbook.

Список изменений представлен в файле UPDATING

20121205:
9.1-RELEASE.

20120727:
The sparc64 ZFS loader has been changed to no longer try to auto-
detect ZFS providers based on diskN aliases but now requires these
to be explicitly listed in the OFW boot-device environment variable.

20120422:
Now unix domain sockets behave «as expected» on nullfs(5). Previously
nullfs(5) did not pass through all behaviours to the underlying layer,
as a result if we bound to a socket on the lower layer we could connect
only to the lower path; if we bound to the upper layer we could connect
only to the upper path. The new behavior is one can connect to both the
lower and the upper paths regardless what layer path one binds to.

20120109:
The acpi_wmi(4) status device /dev/wmistat has been renamed to
/dev/wmistat0.

20120106:
A new VOP_ADVISE() was added to support posix_fadvise(2). All
filesystem modules must be recompiled.

20120106:
The interface of the VOP_VPTOCNP(9) changed, now the returned
vnode shall be referenced, previously it was required to be
only held. All in-tree filesystems are converted.
litos @litos
карма
3,0
рейтинг 0,0
Реклама помогает поддерживать и развивать наши сервисы

Подробнее
Реклама

Самое читаемое

Комментарии (16)

  • +1
    Интересно, почему не было анонса?
    • +1
      Скорее всего потому, что не готовы еще пакеты для бинарного обновления и также бинарные пакеты портов которые ставятся через pkg_add также еще не все скомпилированы.
    • 0
      Ну, обычная практика, не только для FreeBSD — чтобы не создавать сразу ажиотажа, на сколько я понимаю.
  • 0
    Вот каждый раз думаю, когда выходит новая версия — обновляться или нет.
    На некоторых шлюзах до сих пор стоит 6.3 и ничего, работает, годами туда не залезаю…
    • +2
      У нас есть один сервер с FreeBSD 6.x, он прекрасно «просто работает».
      Но есть проблемы с некотырми портами, есть проблемы с zfs, с настройкой роутинга и т.п. Т.е. проблемы возникают тогда, когда нужно сделать что-то новое. Если же Вам ничего менять не нужно и всё устраивает, то действительно обновляться смысла нет.
      • 0
        Следует понимать также, что FreeBSD 6.x официально не поддерживается уже как 2 года, что может быть опасным в плане безопасности если там стоит какой-либо старый софт из портов который не «тупо роутер с ssh с IPадреса админа»
        Сразу скажу, что 9ка потребляет несколько больше (насколько точных сведений нет) больше ресурсов и в случае очень старого железа это может быть критично.
        • 0
          для такого железа есть NetBSD или QNX (embedded имеется ввиду)
      • НЛО прилетело и опубликовало эту надпись здесь
        • 0
          О том и речь.
  • 0
    Хотя бы перевели UPDATING для кошерности…
    • +3
      20121205: (обновление от 05 декабря 2012)
      9.1-RELEASE.
      (релиз версия 9.1)

      20120727: (обновление от 27 июля 2012)
      The sparc64 ZFS loader has been changed to no longer try to auto-
      detect ZFS providers based on diskN aliases but now requires these
      to be explicitly listed in the OFW boot-device environment variable.
      (Модуль загрузчика ZFS под архитектуру SPARC64 был изменен и более не пытается автоматически определить наличие ZFS которые расположены на diskN алиасах устройств, однако если теперь требуется то должно быть описано в OFW переменного окружения загрузочного устройства)

      20120422: (обновление от 22 апреля 2012)
      Now unix domain sockets behave «as expected» on nullfs(5). Previously
      nullfs(5) did not pass through all behaviours to the underlying layer,
      as a result if we bound to a socket on the lower layer we could connect
      only to the lower path; if we bound to the upper layer we could connect
      only to the upper path. The new behavior is one can connect to both the
      lower and the upper paths regardless what layer path one binds to.

      20120109: (обновление от 9 января 2012)
      The acpi_wmi(4) status device /dev/wmistat has been renamed to
      /dev/wmistat0.
      (Виртуальное устройство для получения статуса acpi_wmi(4) переименовано на /dev/wmistat0)

      20120106: (обновление от 6 января 2012)
      A new VOP_ADVISE() was added to support posix_fadvise(2). All
      filesystem modules must be recompiled.
      (Добавлена VOP_ADVISE() для поддержки добавленной postix_fadvise(2). Все модули реализации файловых систем должны быть перекомпилированы)

      20120106: (обновление от 06 января 2012)
      The interface of the VOP_VPTOCNP(9) changed, now the returned
      vnode shall be referenced, previously it was required to be
      only held. All in-tree filesystems are converted.
      (Интерфейс для VOP_VPTOCNP(9) изменен и теперь возвращяет vnode на который будет ссылка (определение), ранее этого требовало только состояние. Все in-tree файловые системы конвертированы)
  • –1
    В общем изменения довольно незначительные…
    Все видимо на 10ку направлено
    • +1
      На самом деле если посмотреть историю коммитов в svn то изменений весьма и весьма много, тут просто отражены не все.
  • 0
    Там же вроде обещали KMS запилить, а, соответственно, нормальные драйвера для видео Sandy/Ivy Bridge. Оно случилось? Или таки нет?
    • 0
      мне вот интересно зачем они Вам на сервере? Как GPU для расчетов использовать не нужно, а для всего остального есть консоль, а для работы на месте — VESA режим, они и без драйверов работает.
      • 0
        А кто сказал «на сервере»? При наличии нормальных драйверов на видео, я бы с удовольствием попробовал её у себя на ноутбуке

Только зарегистрированные пользователи могут оставлять комментарии. Войдите, пожалуйста.